Ubuntu 14.04 instalación


#1

Hola a todos tengo un problema con el IDE de arduino, no me aparecen las placas de altair
previo a esto clone la carpeta de altair dentro de la carpeta harware como lo indican en la
instalación y solo me aparecen los ejemplos pero no las placas.

Ademas tengo un error al correr aquila server me aparece lo siguiente.
npm http GET https://registry.npmjs.org/aquila-server
npm http 304 https://registry.npmjs.org/aquila-server
npm WARN engine aquila-server@0.2.1: wanted: {“node”:">=0.12.0 <4.0.0"} (current: {“node”:“v0.10.25”,“npm”:“1.3.10”})
npm ERR! Error: EACCES, mkdir '/usr/local/lib/node_modules’
npm ERR! { [Error: EACCES, mkdir ‘/usr/local/lib/node_modules’]
npm ERR! errno: 3,
npm ERR! code: ‘EACCES’,
npm ERR! path: ‘/usr/local/lib/node_modules’,
npm ERR! fstream_type: ‘Directory’,
npm ERR! fstream_path: ‘/usr/local/lib/node_modules/aquila-server’,
npm ERR! fstream_class: ‘DirWriter’,
npm ERR! fstream_stack:
npm ERR! [ ‘/usr/lib/nodejs/fstream/lib/writer.js:171:23’,
npm ERR! ‘/usr/lib/nodejs/mkdirp/index.js:37:53’,
npm ERR! ‘Object.oncomplete (fs.js:107:15)’ ] }
npm ERR!
npm ERR! Please try running this command again as root/Administrator.

npm ERR! System Linux 3.19.0-56-generic
npm ERR! command “/usr/bin/nodejs” “/usr/bin/npm” “install” “aquila-server” "-g"
npm ERR! cwd /home/phoenix
npm ERR! node -v v0.10.25
npm ERR! npm -v 1.3.10
npm ERR! path /usr/local/lib/node_modules
npm ERR! fstream_path /usr/local/lib/node_modules/aquila-server
npm ERR! fstream_type Directory
npm ERR! fstream_class DirWriter
npm ERR! code EACCES
npm ERR! errno 3
npm ERR! stack Error: EACCES, mkdir '/usr/local/lib/node_modules’
npm ERR! fstream_stack /usr/lib/nodejs/fstream/lib/writer.js:171:23
npm ERR! fstream_stack /usr/lib/nodejs/mkdirp/index.js:37:53
npm ERR! fstream_stack Object.oncomplete (fs.js:107:15)
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /home/phoenix/npm-debug.log
npm ERR! not ok code 0

Espero me puedan ayudar


#2

Hola @Phoenix, Sobre el IDE de Arduino, ¿Que versión tienes? Aquila requiere la versión 1.6.5 para funcionar, versiones anteriores no funcionan ya que utilizaban un formato diferente para las definiciones de placas.

Sobre aquila-server, veo que tienes la versión 0.10.25 de node, aquila-server requiere la versión 0.12.x para funcionar, puedes instalar esta versión desde algún PPA para Ubuntu.

Saludos.


#3

Hola @rodmg4 !
sigo con el mismo problema cambie mi versión de arduino por la 1.6.5 y tampoco solo me aparecen los ejemplos de altair mas no las placas.
con respecto a lo del problema con aquila server ya quedo resuelto actualizando a la version a la 0.12


#4

Qué extraño, asegúrate de que la definición de hardware esté en la carpeta correcta en ~/Arduino/hardware/altair-arduinoide como dice en: http://www.aquila.io/es/downloads_linux

Y que tengas la versión correcta del IDE abierto (me ha pasado que se queda instalada igual la versión anterior de arduino y sin darnos cuenta la abrimos en vez de la nueva)


#5

Era ese pequeño detalle se quedo la versión antigua y es la que me abría y no me había dado cuenta.
Muchas gracias por el apoyo!