Update de mongodb


#1

Hola, intenté instalar hace unos dias el servidor de aquila a la raspberry, todo parece estar bien pero cuando ejecuto el servidor me sale este error

DeprecationWarning: open() is deprecated in mongoose >= 4.11.0, use openUri() instead, or set the useMongoClient option if using connect() or createConnection()

Lei que se actualizó el mongodb y que hay que cambiar una función pero no tengo idea de donde se hace eso. Pueden ayudarme? Saludos


#2

Hola, veo que es una advertencia de una función deprecada, pero aún así debería funcionar, ¿se cierra el proceso cuando sale?.


#3

Si, se detiene, no inicia el servidor. Me da otros errores, deja te pongo una captura de pantalla


#4

Hola Senor esta verdad conmigo la responder a ti preguntas. Es muy simplicitir toda tu tienes que hacer. npm Retiran mongoose mientras npm instala mongoose@4.10.8—salvos


#5

no entendí :frowning:


#6

Retira mongoose entonces instala mongoose 4.10.8


#7

A lo que se refiere es que tienes que instalar una versión más reciente de mongoose en el proyecto con el comando:

npm install mongoose@4.10.8 --save

Sin embargo esto no funcionará por que veo que tienes instalado aquila-server en forma global, para poder hacer esto tendrías que instalarlo de forma manual desde este repositorio: https://github.com/makerlabmx/aquila-api-hub

Esto pasa debido a que este software ya no está soportado por lo que se quedó desactualizado, sin embargo si puedes actualizarlo y hacer un pull request en github te lo agradecería mucho.

Esto tiene que ver con cómo funcionan las dependencias en node.js, te recomiendo que te leas algún tutorial de node para que puedas modificarlo.


#8

Viendo la captura que publicaste veo que la causa del cierre no es por mongoose, si no por bcrypt, por alguna razón se instaló una versión incorrecta del módulo nativo de bcrypt, te recomiendo intentar reinstalarlo asegurándote que tengas el paquete build-essential instalado en tu sistema.


#9

ah si, de hecho si arregló el otro error que tenía, al instalar el mongoose de la versión correcta, pero ahora me sale esto (2 partes de capturas de pantallas)

CLICK PARA EXPANDIR IMAGENES


#10

Ahora el problema parece que es por que la nueva versión de mongoose ya no es compatible con node 4.X (el mensaje de “Use of const in strict mode” me parece que es por características nuevas de javascript que se han ido agregando en versiones recientes de node que no estaban soportadas en la rama 4.X), puedes intentar con node 6.12.X pero no se si se rompa otra cosa.